Windows driver software

VCI V4 driver supporting the Ixxat CAN interfaces and Ixxat INpact
under Windows 10 (32/64) / Windows 8 (32/64) / Windows 7 (32/64)

 

The VCI V4 (Virtual Communication Interface) is the driver interface for Ixxat Interfaces under Windows. Based on the VCI customer specific applications can be developed for communication via CAN, CAN-FD, LIN and Industrial Ethernet (see supported APIs).

Besides drivers and programming APIs, the ZIP packages contain also manuals, programming samples and further add-ons. The canAnalyser3 Mini tool is included in the VCI V4 download package and enables first analysis steps within CAN networks for the Ixxat CAN(FD) PC interfaces. canAnalyser Mini is automatically installed during the driver installation.

Drivers
For new applications please download the latest V4 driver version which supports the Ixxat INpact and all current PC CAN interfaces.
Previous versions of the driver support older operating system but do not support all PC interfaces and the Ixxat INpact.

Contents of the VCI V4 ZIP package:

  • VCI installation file including canAnalyser Mini installation
  • VCI installation manual and programming manuals for the different APIs
  • Mapper von VCI2 auf VCI4
  • JAVA API, LabView API
FileVersionSizeDownload
VCI V4 - Windows 10, 8, 7 [Driver, Manuals, Add-ons]4.0.939.072.50 MB Download
VCI V4 - Windows 10, 8, 7 - Release Information4.0.939.01.02 MB Download
VCI V3 - Windows 8, 7, XP SP2, 2000, Vista [Driver, Manuals, Samples, Add-ons]3.5.4.454385.82 MB Download
VCI V2 - Windows 8, 7, XP, 2000, Vista, 9x, Me, NT4 [Driver, Manuals, Samples, Add-ons]2.20.855.027.50 MB Download

General overview of the various drivers and supported interfaces
Click to see more...

CAN Interface Windows QNX INtime RTX VxWorks Linux SocketCAN CANopen
Master API
CoDeSys LabView D-PDU-API
(VCI) (ECI) (ECI) (ECI) (ECI) (ECI)
based on VCI based on VCI based on VCI based on VCI
CANnector








R*
CAN-IB640/PCIe R*
R*
R*
SC*





R*
CAN-IB600/PCIe R*
R*
R*
SC*





CAN-IB500/PCIe R*
R*
R*
SC*





R*
CAN-IB200/PCIe R*
R*
R*
SC*





R*
CAN-IB100/PCIe R*
R*
R*
SC*





R*
CAN-IB520/PCIe Mini
R*
R*
R*
SC*





R*
CAN-IB120/PCIe Mini
R*
R*
R*
SC*





R*
CAN-IB630/PCIe 104
R*
R*
R*
SC*





R*
CAN-IB230/PCIe 104
R*
R*
R*
SC*





R*
CAN-IB130/PCIe 104
R*
R*
R*
SC*





R*
CAN-IB810/PMC R*
R*
R*
SC*





R*
CAN-IB410/PMC R*
R*
R*
SC*





R*
CAN-IB400/PCI R*
R*
R*
SC*





R*
CAN-IB300/PCI R*
R*
R*
SC*





R*
USB-to-CAN FD R*
R*
R*
SC*





USB-to-CAN V2
R*
R*
R*
SC*





R*
USB-to-CAN Plugin
R*
R*
R*
SC*





R*
simplyCAN O*



O*





CAN@net NT 100/200/420
R*
R*
R*
SC*





R*
CAN@net II VCI
R*
R*
R*
SC*





R*
CANblue II
R*
R*
R*
SC*





R*

G* = with "generic" mode
O* = no driver installation required under latest Windows and Linux OS
R* = Please ask for availability. We will discuss the required steps with you.
SC* = Source code with configurable makefile to target different platforms available on request (NDA required)

 

 

INpact
Multi-Protocol Interface
Windows INtime
6.3.18x
Linux
(VCI) (ECI) (ECI)
Ixxat INpact PCIe Slave* (x86, x86 64 Bit, ARM)
Ixxat INpact PCIe Mini Slave* (x86, x86 64 Bit, ARM)
Ixxat INpact PCIe M.2 Slave* (x86, x86 64 Bit, ARM)

* = all supported protocol versions

Please note

  • For Windows 7 an installed SP1 (Service Pack 1) is required for installation of the VCI V4.
  • Under certain circumstances, the PCI card versions are not displayed correctly in the Windows Device Manager after installation. In this case, please run in a command window with administrator rights the command <bcdedit / set {current} PCIexpress forcedisable>. This deactivates the "PCI Express Native Control" and enables the original PCI Express functions. 
  • The VCI-V3 and VCI-V4 programming interface differs from the programming interface of the VCI V2. If you have software, which has been developed for use with the VCI 2.x, for example OEM software, please check whether the software supports the current VCI driver before installing.